What's new

Potrzebuje Pomocy Z Konfiguracją Silnika 0.3.6 Pod System Debian 10!.

DBRebirth

New User
Joined
May 29, 2022
Messages
1
Reaction score
0
Mianowice chodzi o to że mam problem z konfiguracja silnika pod system debian "10". Na debianie "7" chodziło znakomicie zero błędów przy komplikacji i wgl , a na debianie 10 nie mogę z komplikować plików!. [Za pomoc oraz wyjaśnienie na czym polegała przyczyna jest znakomite wynagrodzenie].
Pozdrawiam Serdecznie
 

Placek

Blue Waffle
Joined
Sep 30, 2008
Messages
6,784
Reaction score
666
Age
7
Zależności. Piekło zależności.

Na wheezym miałeś w repo dostępne paczki np z niezbędnymi bibliotekami do kompilacji silnika.
Silnik był tworzony jakoś w okresie kiedy wheezy był stable.
W nowszym systemie (buster) paczki w starszych wersjach często są już niedostępne, zastąpione nowszymi wersjami.

Za przykład tutaj może posłużyć libboost.
Na przykład na busterze masz libboost1.67-dev:
Na stretchu masz libboost1.62-dev:
Na wheezy było chyba libboost1.41-dev.

To może powodować problemy.

Pytanie jak to rozwiązać?
Możesz dalej używać starszego debiana (wheezy). Ale to średnie podejście, bo to już nieaktualny system który nie dostaje nawet łatek security ( ).
Możesz poszukać paczek z libkami w odpowiednich wersjach i zainstalować je ręcznie na nowszym systemie, licząc, że zadziała. Ale to też średnie podejście, bo prawdopodobnie nie będzie to działać poprawnie, albo przynajmniej zrobi ci śmietnik w systemie którego potem łatwo nie posprzątasz.

Imo najlepszą opcją jest użycie nowego silnika a nie trzymanie się takich staroci. Aktualnie nowsze tfsy czy nawet jakieś silniki br wspierają po kilka wersji tibii. Możesz odpalić np tfsa 1.5 z obsługą protokołu 8.6 czy jakiegoś 7.x i to będzie działać + masz nowy silnik razem ze wsparciem community.
 

Placek

Blue Waffle
Joined
Sep 30, 2008
Messages
6,784
Reaction score
666
Age
7
Poproszę moje znakomite wynagrodzenie xD
 
Top